Unverified Commit 86a2f280 authored by mathieui's avatar mathieui
Browse files

Document that slixmpp is now 3.5+ only

parent 490f15b8
Pre-requisites:
- Python 3.4
- Python 3.5+
- Cython 0.22 and libidn, optionally (making JID faster by compiling the stringprep module)
Install:
......
Slixmpp
#########
Slixmpp is an MIT licensed XMPP library for Python 3.4+. It is a fork of
Slixmpp is an MIT licensed XMPP library for Python 3.5+. It is a fork of
SleekXMPP.
Slixmpp's goals is to only rewrite the core of the library (the low level
......
......@@ -3,8 +3,8 @@
Differences from SleekXMPP
==========================
**Python 3.4+ only**
slixmpp will only work on python 3.4 and above.
**Python 3.5+ only**
slixmpp will only work on python 3.5 and above.
**Stanza copies**
The same stanza object is given through all the handlers; a handler that
......
......@@ -21,7 +21,7 @@ Slixmpp
which goal is to use asyncio instead of threads to handle networking. See
:ref:`differences`.
Slixmpp is an :ref:`MIT licensed <license>` XMPP library for Python 3.4+,
Slixmpp is an :ref:`MIT licensed <license>` XMPP library for Python 3.5+,
Slixmpp's design goals and philosphy are:
......
......@@ -29,9 +29,9 @@ CLASSIFIERS = [
'Intended Audience :: Developers',
'License :: OSI Approved :: MIT License',
'Programming Language :: Python',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Topic :: Internet :: XMPP',
'Topic :: Software Development :: Libraries :: Python Modules',
]
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment