Commit c7c35879 authored by Maxime Buquet's avatar Maxime Buquet

Merge branch 'python-version' into 'master'

Update Python version minimum requirement to 3.7

See merge request poezio/poezio!87
parents ed8f3b5c 64ed3787
...@@ -38,33 +38,6 @@ security-check: ...@@ -38,33 +38,6 @@ security-check:
- pip3 install safety - pip3 install safety
- safety check -r requirements.txt - safety check -r requirements.txt
pytest-3.5:
stage: test
image: python:3.5
script:
- apt-get update && apt-get install -y libidn11-dev
- pip install 'aiohttp<4.0'
- git clone git://git.louiz.org/slixmpp
- pip3 install pytest pyasn1-modules cffi --upgrade
- cd slixmpp
- python3 setup.py install
- cd ..
- python3 setup.py install
- py.test -v test/
pytest-3.6:
stage: test
image: python:3.6
script:
- apt-get update && apt-get install -y libidn11-dev
- git clone git://git.louiz.org/slixmpp
- pip3 install pytest pyasn1-modules cffi --upgrade
- cd slixmpp
- python3 setup.py install
- cd ..
- python3 setup.py install
- py.test -v test/
pytest-3.7: pytest-3.7:
stage: test stage: test
image: python:3.7 image: python:3.7
......
language: python language: python
python: python:
- "3.5"
- "3.6"
- "3.7" - "3.7"
- "3.8-dev" - "3.8-dev"
install: install:
......
...@@ -3,7 +3,7 @@ ...@@ -3,7 +3,7 @@
Installing poezio Installing poezio
================= =================
.. warning:: Python 3.5 or above is **required**. .. warning:: Python 3.7 or above is **required**.
To install it on a distribution that doesn't provide it, see :ref:`pyenv <pyenv-install>`. To install it on a distribution that doesn't provide it, see :ref:`pyenv <pyenv-install>`.
poezio in the GNU/Linux distributions poezio in the GNU/Linux distributions
...@@ -60,7 +60,7 @@ support. Therefore, you might want to use the git version. ...@@ -60,7 +60,7 @@ support. Therefore, you might want to use the git version.
General General
""""""" """""""
Poezio is a python3.5 (and above)-only application, so you will first need that. Poezio is a python3.7 (and above)-only application, so you will first need that.
Packages required for building poezio and deps: Packages required for building poezio and deps:
......
...@@ -24,6 +24,6 @@ else ...@@ -24,6 +24,6 @@ else
PYTHON3=python3 PYTHON3=python3
fi fi
$PYTHON3 -c 'import sys;(print("Python 3.5 or newer is required") and exit(1)) if sys.version_info < (3, 5) else exit(0)' || exit 1 $PYTHON3 -c 'import sys;(print("Python 3.7 or newer is required") and exit(1)) if sys.version_info < (3, 7) else exit(0)' || exit 1
exec "$PYTHON3" -m poezio --custom-version "$args" "$@" exec "$PYTHON3" -m poezio --custom-version "$args" "$@"
git+https://github.com/afflux/pure-python-otr.git#egg=python-potr git+https://github.com/afflux/pure-python-otr.git#egg=python-potr
pyinotify pyinotify
python-mpd2 python-mpd2
aiohttp<4 ; python_version <= '3.5' aiohttp
aiohttp ; python_version > '3.5'
pygments pygments
...@@ -111,9 +111,8 @@ setup(name="poezio", ...@@ -111,9 +111,8 @@ setup(name="poezio",
'License :: OSI Approved :: zlib/libpng License', 'License :: OSI Approved :: zlib/libpng License',
'Natural Language :: English', 'Natural Language :: English',
'Operating System :: Unix', 'Operating System :: Unix',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.7', 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3 :: Only'], 'Programming Language :: Python :: 3 :: Only'],
keywords=['jabber', 'xmpp', 'client', 'chat', 'im', 'console'], keywords=['jabber', 'xmpp', 'client', 'chat', 'im', 'console'],
packages=['poezio', 'poezio.core', 'poezio.tabs', 'poezio.windows', packages=['poezio', 'poezio.core', 'poezio.tabs', 'poezio.windows',
......
...@@ -23,7 +23,7 @@ command -v "$POEZIO_PYTHON" > /dev/null 2>&1 || { ...@@ -23,7 +23,7 @@ command -v "$POEZIO_PYTHON" > /dev/null 2>&1 || {
} }
$POEZIO_PYTHON -c 'import venv' &> /dev/null || { $POEZIO_PYTHON -c 'import venv' &> /dev/null || {
echo "'$POEZIO_PYTHON' venv module not found. Check that you have python (>= 3.5) installed," echo "'$POEZIO_PYTHON' venv module not found. Check that you have python (>= 3.7) installed,"
exit 1 exit 1
} }
...@@ -43,7 +43,7 @@ then ...@@ -43,7 +43,7 @@ then
. "$POEZIO_VENV/bin/activate" . "$POEZIO_VENV/bin/activate"
echo 'Updating the in-venv pip' echo 'Updating the in-venv pip'
pip install --upgrade pip pip install --upgrade pip
python3 -c 'import sys;(print("Python 3.5 or newer is required") and exit(1)) if sys.version_info < (3, 5) else exit(0)' || exit 1 python3 -c 'import sys;(print("Python 3.7 or newer is required") and exit(1)) if sys.version_info < (3, 7) else exit(0)' || exit 1
echo 'Updating the poezio dependencies' echo 'Updating the poezio dependencies'
pip install -r requirements.txt --upgrade pip install -r requirements.txt --upgrade
echo 'Updating the poezio plugin dependencies' echo 'Updating the poezio plugin dependencies'
...@@ -55,7 +55,7 @@ else ...@@ -55,7 +55,7 @@ else
. "$POEZIO_VENV/bin/activate" . "$POEZIO_VENV/bin/activate"
cd "$POEZIO_VENV" # needed to download slixmpp inside the venv cd "$POEZIO_VENV" # needed to download slixmpp inside the venv
python3 -c 'import sys;(print("Python 3.5 or newer is required") and exit(1)) if sys.version_info < (3, 5) else exit(0)' || exit 1 python3 -c 'import sys;(print("Python 3.7 or newer is required") and exit(1)) if sys.version_info < (3, 7) else exit(0)' || exit 1
echo 'Installing the poezio dependencies using pip' echo 'Installing the poezio dependencies using pip'
pip install -r "../requirements.txt" pip install -r "../requirements.txt"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment