Commit 4b51ce97 authored by mathieui's avatar mathieui

Fix update.sh for debian (?)

hopefully
parent e8e1e1bb
......@@ -17,17 +17,15 @@ then
POEZIO_PYTHON=python3
fi
if ! command -v "$POEZIO_PYTHON" > /dev/null 2>&1
then
command -v "$POEZIO_PYTHON" > /dev/null 2>&1 || {
echo "Python executable '$POEZIO_PYTHON' not found."
exit 1
fi
}
if ! $POEZIO_PYTHON -c 'import venv' &> /dev/null
then
$POEZIO_PYTHON -c 'import venv' &> /dev/null || {
echo "'$POEZIO_PYTHON' venv module not found. Check that you have python (>= 3.4) installed,"
exit 1
fi
}
echo 'Updating poezio'
git pull --ff-only origin master || {
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment