Commit b5f7e599 authored by louiz’'s avatar louiz’

Update the images and .spec to use sphinx instead of pandoc

parent 2f0078eb
......@@ -26,6 +26,7 @@ RUN apk add --no-cache g++\
python3-dev\
automake\
autoconf\
libffi-dev\
flex\
bison\
libltdl\
......
# This Dockerfile creates a docker image suitable to run biboumi’s build and
# tests. For example, it can be used on with gitlab-ci.
FROM docker.io/debian:latest
FROM docker.io/debian:buster
ENV LC_ALL C.UTF-8
......@@ -22,8 +22,8 @@ RUN apt install -y g++\
libidn11-dev\
uuid-dev\
libsystemd-dev\
pandoc\
libasan3\
python3-sphinx\
libasan5\
libubsan0\
git\
python3-lxml\
......@@ -46,7 +46,7 @@ RUN apt install -y g++\
RUN git clone https://github.com/randombit/botan.git && cd botan && ./configure.py --prefix=/usr && make -j8 && make install && rm -rf /botan
# Install slixmpp, for e2e tests
RUN git clone https://github.com/saghul/aiodns.git && cd aiodns && git checkout 7ee13f9bea25784322~ && python3 setup.py build && python3 setup.py install && git clone git://git.louiz.org/slixmpp && pip3 install pyasn1==0.4.2 && cd slixmpp && python3 setup.py build && python3 setup.py install
RUN git clone https://github.com/saghul/aiodns.git && cd aiodns && git checkout 7ee13f9bea25784322~ && python3 setup.py build && python3 setup.py install && git clone git://git.louiz.org/slixmpp && pip3 install pyasn1 && cd slixmpp && python3 setup.py build && python3 setup.py install
RUN useradd tester -m
......
......@@ -20,7 +20,7 @@ RUN dnf --refresh install -y\
libidn-devel\
uuid-devel\
systemd-devel\
pandoc\
python3-sphinx\
libasan\
libubsan\
git\
......
......@@ -16,7 +16,7 @@ BuildRequires: postgresql-devel
BuildRequires: botan2-devel
BuildRequires: cmake
BuildRequires: systemd
BuildRequires: pandoc
BuildRequires: python3-sphinx
%global _hardened_build 1
......@@ -67,6 +67,7 @@ make check %{?_smp_mflags}
* ${RPM_DATE} Le Coz Florent <louiz@louiz.org> - ${RPM_VERSION}-1
- Build latest git revision
- Build against botan2
- Build with sphinx instead of pandoc
* Fri Jun 1 2018 Le Coz Florent <louiz@louiz.org> - 8.3-1
Update to version 8.3
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment